use strict;
my $str = '[a]
1
2
3
[b]
1
2
3
[c]
1
2
3
[d]
1
2
3';
my $regex = qr/(?=\R\[)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";