re = /(?=\R\[)/m
str = '[a]
1
2
3
[b]
1
2
3
[c]
1
2
3
[d]
1
2
3'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result