import re
regex = re.compile(r"(?=\R\[)", flags=re.MULTILINE)
test_str = ("[a]\n"
"1\n"
"2\n"
"3\n"
"[b]\n"
"1\n"
"2\n"
"3\n"
"[c]\n"
"1\n"
"2\n"
"3\n"
"[d]\n"
"1\n"
"2\n"
"3")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)