import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\R\\[)";
final String string = "[a]\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "[b]\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "[c]\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "[d]\n"
+ "1\n"
+ "2\n"
+ "3";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}