#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)^StartWord\R+\K.*?\R(?=\R*^StopWord\R)"
Local $sString = "Delete this text De l e te this text" & @CRLF & _
"" & @CRLF & _
"StartWord" & @CRLF & _
"" & @CRLF & _
"Apples Oranges" & @CRLF & _
"Pears Grapes" & @CRLF & _
"" & @CRLF & _
"StopWord" & @CRLF & _
"" & @CRLF & _
"Delete this text Delete this text" & @CRLF & _
"" & @CRLF & _
"StartWord" & @CRLF & _
"" & @CRLF & _
"Peas Carrots" & @CRLF & _
"Peas Carrots" & @CRLF & _
"" & @CRLF & _
"StopWord" & @CRLF & _
"" & @CRLF & _
"Delete this text Delete this text" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)