using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^StartWord\R+\K.*?\R(?=\R*^StopWord\R)";
string substitution = @"";
string input = @"Delete this text De l e te this text
StartWord
Apples Oranges
Pears Grapes
StopWord
Delete this text Delete this text
StartWord
Peas Carrots
Peas Carrots
StopWord
Delete this text Delete this text
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}