import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^StartWord\\R+\\K.*?\\R(?=\\R*^StopWord\\R)";
final String string = "Delete this text De l e te this text\n\n"
+ "StartWord\n\n"
+ "Apples Oranges\n"
+ "Pears Grapes\n\n"
+ "StopWord\n\n"
+ "Delete this text Delete this text\n\n"
+ "StartWord\n\n"
+ "Peas Carrots\n"
+ "Peas Carrots\n\n"
+ "StopWord\n\n"
+ "Delete this text Delete this text\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}