const regex = /^StartWord\R+\K.*?\R(?=\R*^StopWord\R)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^StartWord\\R+\\K.*?\\R(?=\\R*^StopWord\\R)', 'gms')
const str = `Delete this text De l e te this text
StartWord
Apples Oranges
Pears Grapes
StopWord
Delete this text Delete this text
StartWord
Peas Carrots
Peas Carrots
StopWord
Delete this text Delete this text
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);