re = /^StartWord\R+\K.*?\R(?=\R*^StopWord\R)/m
str = 'Delete this text De l e te this text
StartWord
Apples Oranges
Pears Grapes
StopWord
Delete this text Delete this text
StartWord
Peas Carrots
Peas Carrots
StopWord
Delete this text Delete this text
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result