use strict;
my $str = 'Delete this text De l e te this text
StartWord
Apples Oranges
Pears Grapes
StopWord
Delete this text Delete this text
StartWord
Peas Carrots
Peas Carrots
StopWord
Delete this text Delete this text
';
my $regex = qr/^StartWord\R+\K.*?\R(?=\R*^StopWord\R)/msp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";