# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^StartWord\R+\K.*?\R(?=\R*^StopWord\R)"
test_str = ("Delete this text De l e te this text\n\n"
"StartWord\n\n"
"Apples Oranges\n"
"Pears Grapes\n\n"
"StopWord\n\n"
"Delete this text Delete this text\n\n"
"StartWord\n\n"
"Peas Carrots\n"
"Peas Carrots\n\n"
"StopWord\n\n"
"Delete this text Delete this text\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.