#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b([AW|BW|AS]{2})(\d{4})"
Local $sString = "AW0001" & @CRLF & _
"AW0002" & @CRLF & _
"BW0001" & @CRLF & _
"BW0002" & @CRLF & _
"AS0001" & @CRLF & _
"BS0002" & @CRLF & _
"AW0001" & @CRLF & _
"AW0002" & @CRLF & _
"BW0001" & @CRLF & _
"BW0002" & @CRLF & _
"AS0001" & @CRLF & _
"BS0002" & @CRLF & _
"AG0002"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")