const regex = /\b([AW|BW|AS]{2})(\d{4})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([AW|BW|AS]{2})(\\d{4})', 'gmi')
const str = `AW0001
AW0002
BW0001
BW0002
AS0001
BS0002
AW0001
AW0002
BW0001
BW0002
AS0001
BS0002
AG0002`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}