// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b([AW|BW|AS]{2})(\d{4})").unwrap();
let string = "AW0001
AW0002
BW0001
BW0002
AS0001
BS0002
AW0001
AW0002
BW0001
BW0002
AS0001
BS0002
AG0002";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}