import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([AW|BW|AS]{2})(\\d{4})";
final String string = "AW0001\n"
+ "AW0002\n"
+ "BW0001\n"
+ "BW0002\n"
+ "AS0001\n"
+ "BS0002\n"
+ "AW0001\n"
+ "AW0002\n"
+ "BW0001\n"
+ "BW0002\n"
+ "AS0001\n"
+ "BS0002\n"
+ "AG0002";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}