$re = '/\b([AW|BW|AS]{2})(\d{4})/mi';
$str = 'AW0001
AW0002
BW0001
BW0002
AS0001
BS0002
AW0001
AW0002
BW0001
BW0002
AS0001
BS0002
AG0002';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);