import re
regex = re.compile(r"\b([AW|BW|AS]{2})(\d{4})", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("AW0001\n"
"AW0002\n"
"BW0001\n"
"BW0002\n"
"AS0001\n"
"BS0002\n"
"AW0001\n"
"AW0002\n"
"BW0001\n"
"BW0002\n"
"AS0001\n"
"BS0002\n"
"AG0002")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")