using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))";
string substitution = @" = NULL";
string input = @"$a, $b, $c, $hi = "", $na";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}