$re = '/(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))/i';
$str = '$a, $b, $c, $hi = "", $na';
$subst = " = NULL";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;