const regex = /(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\$[A-Za-z0-9\\-\\_ ]+)(?=(?:,|$))', 'gi')
const str = `\$a, \$b, \$c, \$hi = "", \$na`;
const subst = ` = NULL`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);