import re
regex = re.compile(r"(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))", flags=re.IGNORECASE)
test_str = "$a, $b, $c, $hi = \"\", $na"
subst = " = NULL"
result = regex.sub(subst, test_str)
if result:
print(result)