re = /(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))/i
str = '$a, $b, $c, $hi = "", $na'
subst = ' = NULL'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result