#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)\b(my|our)\b \b(step-)?(son|daughter|children|child|kid)\b"
Local $sString = "my son" & @CRLF & _
"my daughter" & @CRLF & _
"our son" & @CRLF & _
"he is my son" & @CRLF & _
"me and my son were playing football" & @CRLF & _
"my step-son" & @CRLF & _
"our step-daughter" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")