$re = '/\b(my|our)\b \b(step-)?(son|daughter|children|child|kid)\b/iu';
$str = 'my son
my daughter
our son
he is my son
me and my son were playing football
my step-son
our step-daughter
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);