const regex = new RegExp('\\b(my|our)\\b \\b(step-)?(son|daughter|children|child|kid)\\b', 'giu')
const str = `my son
my daughter
our son
he is my son
me and my son were playing football
my step-son
our step-daughter
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}