use strict;
my $str = 'my son
my daughter
our son
he is my son
me and my son were playing football
my step-son
our step-daughter
';
my $regex = qr/\b(my|our)\b \b(step-)?(son|daughter|children|child|kid)\b/iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}