re = /\b(my|our)\b \b(step-)?(son|daughter|children|child|kid)\b/i
str = 'my son
my daughter
our son
he is my son
me and my son were playing football
my step-son
our step-daughter
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end