using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(my|our)\b \b(step-)?(son|daughter|children|child|kid)\b";
string input = @"my son
my daughter
our son
he is my son
me and my son were playing football
my step-son
our step-daughter
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}