import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(my|our)\\b \\b(step-)?(son|daughter|children|child|kid)\\b";
final String string = "my son\n"
+ "my daughter\n"
+ "our son\n"
+ "he is my son\n"
+ "me and my son were playing football\n"
+ "my step-son\n"
+ "our step-daughter\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}