// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?iu)\b(my|our)\b \b(step-)?(son|daughter|children|child|kid)\b").unwrap();
let string = "my son
my daughter
our son
he is my son
me and my son were playing football
my step-son
our step-daughter
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}