package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:north|south)?(?:east|west)?\b`)
var str = `The westerly barn is a room. The field is east of the barn. The stable is northeast of the field. The forest is northwest of the field.
It matches north, south, east, west, northeast, northwest, southeast, southwest and many many empty strings.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}