import re
regex = re.compile(r"\b(?:north|south)?(?:east|west)?\b", flags=re.MULTILINE)
test_str = ("The westerly barn is a room. The field is east of the barn. The stable is northeast of the field. The forest is northwest of the field.\n\n"
"It matches north, south, east, west, northeast, northwest, southeast, southwest and many many empty strings.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")