const regex = new RegExp('\\b(?:north|south)?(?:east|west)?\\b', 'gm')
const str = `The westerly barn is a room. The field is east of the barn. The stable is northeast of the field. The forest is northwest of the field.
It matches north, south, east, west, northeast, northwest, southeast, southwest and many many empty strings.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}