$re = '/\b(?:north|south)?(?:east|west)?\b/m';
$str = 'The westerly barn is a room. The field is east of the barn. The stable is northeast of the field. The forest is northwest of the field.
It matches north, south, east, west, northeast, northwest, southeast, southwest and many many empty strings.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);