import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:north|south)?(?:east|west)?\\b";
final String string = "The westerly barn is a room. The field is east of the barn. The stable is northeast of the field. The forest is northwest of the field.\n\n"
+ "It matches north, south, east, west, northeast, northwest, southeast, southwest and many many empty strings.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}