re = /\b(?:north|south)?(?:east|west)?\b/m
str = 'The westerly barn is a room. The field is east of the barn. The stable is northeast of the field. The forest is northwest of the field.
It matches north, south, east, west, northeast, northwest, southeast, southwest and many many empty strings.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end