#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)#+(?:.*?)\KWith Space"
Local $sString = "#ThisIsaHashtagWith Space" & @CRLF & _
"With Space"
Local $sSubst = "WithSpace"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)