$re = '/#+(?:.*?)\KWith Space/m';
$str = '#ThisIsaHashtagWith Space
With Space';
$subst = "WithSpace";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;