const regex = /#+(?:.*?)\KWith Space/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#+(?:.*?)\\KWith Space', 'gm')
const str = `#ThisIsaHashtagWith Space
With Space`;
const subst = `WithSpace`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);