use strict;
my $str = '#ThisIsaHashtagWith Space
With Space';
my $regex = qr/#+(?:.*?)\KWith Space/mp;
my $subst = 'WithSpace';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";