import re
regex = re.compile(r"#+(?:.*?)\KWith Space", flags=re.MULTILINE)
test_str = ("#ThisIsaHashtagWith Space\n"
"With Space")
subst = "WithSpace"
result = regex.sub(subst, test_str)
if result:
print(result)