import Foundation
let pattern = ##"#+(?:.*?)\KWith Space"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#ThisIsaHashtagWith Space
With Space
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"WithSpace"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)