using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#+(?:.*?)\KWith Space";
string substitution = @"WithSpace";
string input = @"#ThisIsaHashtagWith Space
With Space";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}