#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^[\p{L}\d!#$%&'*+/=?^_`{|}~-]+(?:\.[\p{L}\d!#$%&'*+/=?^_`{|}~-]+)*@[\p{L}\d]+(?:[.-][\p{L}\d]+)*\.\p{L}{2,}$"
Local $sString = "test.user@example.com" & @CRLF & _
"test-user@ex-ample.com" & @CRLF & _
"test.user+123@example.com" & @CRLF & _
"dörte@sörensen.example.com" & @CRLF & _
"χρήστης@παράδειγμα.ελ" & @CRLF & _
"иван@поща.бг" & @CRLF & _
"خالد@الدوحة.قط" & @CRLF & _
"שלום@דוגמה.ישראל"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")