re = /^[\p{L}\d!#$%&'*+\/=?^_`{|}~-]+(?:\.[\p{L}\d!#$%&'*+\/=?^_`{|}~-]+)*@[\p{L}\d]+(?:[.-][\p{L}\d]+)*\.\p{L}{2,}$/m
str = 'test.user@example.com
test-user@ex-ample.com
test.user+123@example.com
dörte@sörensen.example.com
χρήστης@παράδειγμα.ελ
иван@поща.бг
خالد@الدوحة.قط
שלום@דוגמה.ישראל'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end