package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{L}\d!#$%&'*+/=?^_`{|}~-]+(?:\.[\p{L}\d!#$%&'*+/=?^_`{|}~-]+)*@[\p{L}\d]+(?:[.-][\p{L}\d]+)*\.\p{L}{2,}$`)
var str = `test.user@example.com
test-user@ex-ample.com
test.user+123@example.com
dörte@sörensen.example.com
χρήστης@παράδειγμα.ελ
иван@поща.бг
خالد@الدوحة.قط
שלום@דוגמה.ישראל`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}