use strict;
my $str = 'test.user@example.com
test-user@ex-ample.com
test.user+123@example.com
dörte@sörensen.example.com
χρήστης@παράδειγμα.ελ
иван@поща.бг
خالد@الدوحة.قط
שלום@דוגמה.ישראל';
my $regex = qr/^[\p{L}\d!#$%&'*+/=?^_`{|}~-]+(?:\.[\p{L}\d!#$%&'*+/=?^_`{|}~-]+)*@[\p{L}\d]+(?:[.-][\p{L}\d]+)*\.\p{L}{2,}$/ump;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}