import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\p{L}\\d!#$%&'*+/=?^_`\\{|\\}~-]+(?:\\.[\\p{L}\\d!#$%&'*+/=?^_`\\{|\\}~-]+)*@[\\p{L}\\d]+(?:[.-][\\p{L}\\d]+)*\\.\\p{L}{2,}$";
final String string = "test.user@example.com\n"
+ "test-user@ex-ample.com\n"
+ "test.user+123@example.com\n"
+ "dörte@sörensen.example.com\n"
+ "χρήστης@παράδειγμα.ελ\n"
+ "иван@поща.бг\n"
+ "خالد@الدوحة.قط\n"
+ "שלום@דוגמה.ישראל";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}