const regex = /^[\p{L}\d!#$%&'*+/=?^_`{|}~-]+(?:\.[\p{L}\d!#$%&'*+/=?^_`{|}~-]+)*@[\p{L}\d]+(?:[.-][\p{L}\d]+)*\.\p{L}{2,}$/umg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\p{L}\\d!#$%&\'*+\/=?^_`{|}~-]+(?:\\.[\\p{L}\\d!#$%&\'*+\/=?^_`{|}~-]+)*@[\\p{L}\\d]+(?:[.-][\\p{L}\\d]+)*\\.\\p{L}{2,}$', 'umg')
const str = `test.user@example.com
test-user@ex-ample.com
test.user+123@example.com
dörte@sörensen.example.com
χρήστης@παράδειγμα.ελ
иван@поща.бг
خالد@الدوحة.قط
שלום@דוגמה.ישראל`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}