// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?um)^[\p{L}\d!#$%&'*+/=?^_`{|}~-]+(?:\.[\p{L}\d!#$%&'*+/=?^_`{|}~-]+)*@[\p{L}\d]+(?:[.-][\p{L}\d]+)*\.\p{L}{2,}$").unwrap();
let string = "test.user@example.com
test-user@ex-ample.com
test.user+123@example.com
dörte@sörensen.example.com
χρήστης@παράδειγμα.ελ
иван@поща.бг
خالد@الدوحة.قط
שלום@דוגמה.ישראל";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}